Написать программу в паскале . Если число чётные то делим ** два ,если нечётное то...

0 голосов
107 просмотров

Написать программу в паскале . Если число чётные то делим на два ,если нечётное то возвести в квадрат .


Информатика (18 баллов) | 107 просмотров
Дан 1 ответ
0 голосов

var a: integer;

begin

readln(a);

if a mod 2=0 then writeln (a/2) else writeln (sqr(a));

end.

(6.8k баллов)
0

Думаю, у Вас ошибка. Так как число нужно возвести в квадрат в случае, если оно нечётное, то нужно написать else weriteln (a*a)

0

Также "else..." нужно писать не с новой строчки

0

Также нет названия программы. Остальное всё идеально. Если это я что-то не так понял, скажите.

0

А, понятно, буду знать про sqr. Спасибо