Ниже записана программа. Получив ** вход число x, эта программа печатает два числа....

0 голосов
25 просмотров

Ниже записана программа. Получив на вход число x, эта программа печатает два числа. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 10.
var x, L, M: integer;
begin
readln(x);
L:=0; M:=0;
while x > 0 do begin
L:=L+1;
if (M < x) and (x mod 2 = 1) then begin
M:= (x mod 10) * 2;
end;
x:= x div 10;
end;
writeln(L); write(M);
end.


Информатика (46 баллов) | 25 просмотров
Дан 1 ответ
0 голосов

Будет число 115 вот так

(1.1k баллов)
0

205 :)