1)Составьте программу, выводящую ** экран нечетные числа от 11 до 31.2)Составьте...

0 голосов
151 просмотров

1)Составьте программу, выводящую на экран нечетные числа от 11 до 31.2)Составьте программу, выводящую на экран числа от 1 до 10,а также квадраты и кубы этих чисел в следующем виде:1 1 1 2 4 8 ... 10 100 1000​


Информатика (694 баллов) | 151 просмотров
0

Язык?

0

Что язык?

0

Ну на каком языке оно должно быть сделано? Паскаль, Питон, С/С++?

0

Паскаль

Дано ответов: 2
0 голосов

1) program znanija;

var

i,a: integer;

begin

a:=11;

for i:=1 to 10 do

begin

a := a + 2;

writeln(a);

end;

end.

2) program znanija;

var

i,a,b: integer;

begin

for i:=1 to 10 do

begin

a := sqr(i);

b := i*i*i;

writeln(i, ' ', a, ' ', b);

end;

end.

(243 баллов)
0

Ой, в первом перед строчкой "for i:=1 to 10 do" добавьте "writeln(a);"

0 голосов

Номер 1

Program n_1;

var i:integer;

begin

   for i:=11 to 31 do if i mod 2 = 1 then write(i, ' ');

end.

Номер 2

Program n_1;

var i:integer;

begin

   for i:=1 to 10 do writeln(i, ' ', i*i, ' ', i*i*i);

end.

(3.5k баллов)