Дана сторона квадрата а. Составьте программу, которая будет вычислять его P и S и выводит...

0 голосов
40 просмотров

Дана сторона квадрата а. Составьте программу, которая будет вычислять его P и S и выводит на компьютер​, написать программу


Информатика (17 баллов) | 40 просмотров
Дано ответов: 2
0 голосов

####################


image
(5.6k баллов)
0

Далеко пойдешь с таким кодом... С каких пор переменные в паскале/делфи объявляются в begin?

0

всегда можно было, другое дело что это не всегда уместно.

0

Всегда можно было и можно будет, потому что существует такая вещь, как временные переменные, необходимые для выполнения какого-то цикла или условия. Это было всегда и будет всегда. Как объявлялись переменные в циклах (из-за которых Вы не плачете, почему-то), как объявлялись в блоке begin end в целом, так и будут. У Паскаля никогда не было code style, из-за чего не в праве указывать мне, где я могу указывать, а где нет.

0 голосов

var

   a, p, s : integer;

   

begin

   write('введите сторону квадрата a=');

   readln(a);

   p := a*4;

   s := a*a;

   writeln('периметр P=', p);

   writeln('площадь S=', s);

end.

(1.2k баллов)