Написать программу, которая вводит массив и заменяет в нем все элементы, которые...

0 голосов
68 просмотров

Написать программу, которая вводит массив и заменяет в нем все элементы, которые превышают 7, этим числом. Вывести массив и кол-во замен.(в Pascal)


Информатика (7.9k баллов) | 68 просмотров
Дан 1 ответ
0 голосов

const  

n=10;

var  

a : array [1..n] of integer;

i,k,m : integer;

begin

randomize;

k:=0;

writeln('введите число, на которое заменять элементы: ');

read(m);

writeln('Массив:');

for i:=1 to n do  

 begin

   a[i]:=random(10)+1;

   write(a[i]:4);

 end;

writeln;

for i:=1 to n do  

 if (a[i]>7) then  

   a[i]:=m;

writeln('изменённый массив:');

for i:=1 to n do  

 write(a[i]:4);

end.  

(12.2k баллов)
0

массив заполняется случайными числами, Вам нужно ввести только на какое число заменять

0

да, просто, когда объявляешь массив написать не от 1 до n, а например, от 1 до 5