Напишите программу ,которая:

0 голосов
24 просмотров

Напишите программу ,которая:


image

Информатика (12 баллов) | 24 просмотров
Дан 1 ответ
0 голосов

Var i, t:integer;

A:array[1..22]of integer;

B:array[1..22]of Integer ;

Begin

Write('Изначальный массив') ;

For i:=1 to 22 do begin

A[i]:=random(35)-30;

Write(' ', A[i]) ;End;

Writeln('Реверс массива') ;

For i:=1 to 22 div 2 do begin

T:=A[i];

A[i]:=A[22-i+1];

A[22-i+1]:=t;end;

For i:=1 to 22 do write(' ', A[i]) ;

Writeln('Четные отрицательные элементы массива') ;

For i:=1 to 22 do

If (A[i]<0)and(A[i]mod 2=0)then write(' ', A[i]) ;</p>

End.

(246 баллов)