Напишите программу по обработке данных в потоке так, чтобы она вычисляла сумму только...

0 голосов
291 просмотров

Напишите программу по обработке данных в потоке так, чтобы она вычисляла сумму только положительных чисел:


Информатика (24 баллов) | 291 просмотров
Дан 1 ответ
0 голосов

n = int(input('Введите число символов в потоке: '))

s = 0

for i in range(n):

   a = int(input())

   if a > 0:

       s += a

print(s)

(654k баллов)