Нужно написать программу ** паскале. Создать файл действительных случайных чисел. Найти...

0 голосов
40 просмотров

Нужно написать программу на паскале. Создать файл действительных случайных чисел. Найти наибольший и наименьший элементы и дописать в файл


Информатика (12 баллов) | 40 просмотров
Дан 1 ответ
0 голосов

===== PascalABC.NET =====

begin

 var f := CreateFile&('MyFile.bin');

 // создаем и заполняем файл

 loop 10 do // файл на 10 чисел

   Write(f, Random(100.0));

 // ищем минимум и максимум

 var (min, max) := (200.0, -100.0);

 f.Seek(0);

 var t: real;

 while not f.Eof do

 begin

   Read(f, t);

   if t > max then

     max := t

   else if t < min then

     min := t;

 end;

 // дозапись в файл

 Write(f, max);

 Write(f, min);

 // если надо - контрольный вывод

 f.Seek(0);

 while not f.Eof do

 begin

   Read(f,t);

   Print(t)

 end;

 // закрыть файл

 f.Close;

end.


image
(1.6k баллов)
0

Здравствуйте, извините, что отвлёк, не могли бы глянуть вопрос?

0