ИНФОРМАТИКА, ПАСКАЛЬ, 30 БАЛЛОВ Составить программу, по которой ** экране будет...

0 голосов
45 просмотров

ИНФОРМАТИКА, ПАСКАЛЬ, 30 БАЛЛОВ Составить программу, по которой на экране будет напечатано: «Числа равны (numbers are equal)», если все три заданных числа равны, в противном случае будет напечатано максимальное число.


Информатика (654k баллов) | 45 просмотров
Дан 1 ответ
0 голосов

Объяснение:

Var x, y, z, i:integer;

Begin

Readln(x);

Readln(y);

Readln(z);

If x=y then begin

If y=z then Writeln('numbers are equal' )

else begin if y>z then Writeln(y) else Writeln(z)

End; end

else begin if x>y then i:=x else i:=y;

If i>z then Writeln(i) else Writeln(z) end;

End.

(506 баллов)
0

спасибо, спасли меня!