Написать программу, которая проверяет, является ли введенная с клавиатуры строка двоичным...

0 голосов
185 просмотров

Написать программу, которая проверяет, является ли введенная с клавиатуры строка двоичным числом. Помогите. На PASCAL


Информатика (12 баллов) | 185 просмотров
0

напишите кто знает!

Дан 1 ответ
0 голосов
VAR
   c: Char;
BEGIN
   Assign(input, 'input.txt'); ReSet(input);

   Read(c); 
   If (c <> '1') then begin Write('NO'); Exit; End;

   While (not eoln(input)) do begin
      Read(c);
      If (c <> '0')and(c <> '1') then begin Write('NO'); Exit;
   End;
END.
(733 баллов)