Ребят срочно помогите!!! занятие через 30 мин ( паскаль) 1.Напишите программу, которая...

0 голосов
30 просмотров

Ребят срочно помогите!!! занятие через 30 мин ( паскаль) 1.Напишите программу, которая в последовательности целых чисел определяет количество отрицательных чисел и сумму положительных. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: количество отрицательных чисел и сумму положительных. 2.Напишите программу, которая в последовательности целых чисел определяет максимальное и минимальное число и выводит сумму этих чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000, но не может быть меньше 2. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число — сумму максимального и минимального числа.


Информатика (45 баллов) | 30 просмотров
Дан 1 ответ
0 голосов

Задача 1:

var a,s1,s2: integer;

begin

s1:=0;

s2:=0;

repeat

readln(a);

if (a

else if (a>0) then s2:=s2+a;

until (a=0);  

writeln('Количество отрицательных: ',s1);

writeln('Сумма положительных: ',s2);

end.

Задача 2:

var a,i,n,min,max: integer;

begin

write('Введите кол-во чисел в последовательности: ');

readln(n);

write('Введите ',1,' число: ');

readln(a);

max:=n;

min:=n;

for i:=2 to n do

 begin

 write('Введите ',i,' число: ');

 readln(a);

 if (a>max) then max:=a;

 if (a

 end;

writeln('Минимальное число: ',min);

writeln('Максимальное число: ',max);

writeln('Их сумма: ',min+max);

end.

(2.5k баллов)