ПИТОН Напишите программу, которая заполняет массив из 10 элементов случайными числами в...

0 голосов
1.9k просмотров

ПИТОН Напишите программу, которая заполняет массив из 10 элементов случайными числами в диапазоне [100,300] и выводит его на экран. После этого на экран выводятся средние цифры (число десятков) всех чисел, записанных в массив.Пример:Массив: 142 324 135 257 167 295 126 223 138 270 Число десятков: 4 2 3 5 6 9 2 2 3 7


Информатика (88 баллов) | 1.9k просмотров
Дан 1 ответ
0 голосов

Ответ:

import random

for i in range(10):

   a=random.randint(100,300)

   print()

   print('Число:', a,end=' ')

   s=(a%100)//10

   print('Средняя цифра:', s,end=' ')

Объяснение:


image
image
(130 баллов)