СРОЧНО ПРОШУ НАДО СЕГОДНЯ СДАТЬ!! Написать программу которая запрашивает массив из n...

0 голосов
46 просмотров

СРОЧНО ПРОШУ НАДО СЕГОДНЯ СДАТЬ!! Написать программу которая запрашивает массив из n целых чисел а затем определяет количество четных элементов и количество нечетных элементов и выводит их количество, а также сам исходный массив. 2. Написать программу которая запрашивает массив из н целых чисел, а затем складывает все положительные элементы и все отрицательные элементы и выводит их суммы, а также сам исходный массив.


Информатика (12 баллов) | 46 просмотров
Дан 1 ответ
0 голосов

Ответ:

def parity(array):

   count_chet = 0

   count_nechet = 0

   for i in array:

       if i % 2 == 0:

           count_chet += 1

       else:

           count_nechet += 1

   print('четные числа => ', count_chet)

   print('нечетные числа =>', count_nechet)

   print('кол-во чисел =>', count_nechet + count_chet)

   print(array)

   

parity([1, 2, 4, 5, 7, 8])

(в parity можешь подставить любой массив)

2-ое задание

def suma(numbers_array):

   print(sum(numbers_array))

   print(numbers_array)

suma([1, 2, -4, 5, 7, 8])

Объяснение:

(176 баллов)
0

Спасибо, но под Паскаль можно как нибудь подогнать? :Р

0

извини, Паскаль совершенно не знаю, если бы знал подогнал.