Напишите программу, которая вычисляет произведение всех  чисел кратных 5 в диапазоне от 1...

+589 голосов
394k просмотров

Напишите программу, которая вычисляет произведение всех  чисел кратных 5 в диапазоне от 1 до n (через цикл while) ​


Информатика (75 баллов) | 394k просмотров
Дан 1 ответ
+114 голосов

Ответ:

  • var p, n, i: integer;
  • begin
  • p := 1;
  • readln(n);
  • while i < n do
  • begin
  • i += 1;
  • if (i mod 5 = 0) then p *= i;
  • end;
  • write(p);
  • end.

Пример работоспособности:


image
(3.7k баллов)