Составить программу ** C++ для решения следующей задачи. Дан массив А, состоящий из 10...

+930 голосов
6.0m просмотров

Составить программу на C++ для решения следующей задачи. Дан массив А, состоящий из 10 действительных чисел. Обменять местами минимальный и последний элемент массива. Массив заполнить с клавиатуры и вывести на экран.


Информатика (12 баллов) | 6.0m просмотров
Дан 1 ответ
+88 голосов

#include

#include

using namespace std;

void swap(int *a, int *b){

   int temp = *a;

   *a = *b;

   *b = temp;

}

signed main() {

   const int n = 10;

   vector a(n);

   int mx = -INT_MAX, mn = INT_MAX, i = 0, j = 0;

   for(int k = 0; k < n; k++){

       cin >> a[k];

       if(a[k] > mx){mx = a[k]; i = k;}

       if(a[k] < mn){mn = a[k], j = k;}

   }

   swap(a[i],a[j]);

   for(auto &i:a)

       cout << i << " ";</strong>

}

(156k баллов)