Программирование Паскаль (Делфи 7) 1. Задан массив A(N,N), заполненный целыми...

+92 голосов
2.5m просмотров

Программирование Паскаль (Делфи 7) 1. Задан массив A(N,N), заполненный целыми случайными числами из диапазона [-11;13]. Найти сумму нечетных положительных элементов массива. 2. Задан массив A(N), заполненный случайными целыми числами из диапазона [-16,24]. Составить программу упорядочения массива по убыванию элементов. Чтоб вид имел


Информатика | 2.5m просмотров
Дан 1 ответ
+63 голосов

const

 n=5;

var

 a: array [1..N,1..N]of integer;

 i,j,sum:integer;

begin

 sum:=0;

 for i:=1 to N do

   begin

     for j:=1 to N do

       begin

         a[i,j]:=random(25)-11;

         write(a[i,j]:4);

         if (a[i,j] mod 2 = 1)

           and (a[i,j]>0) then

             sum:=sum+a[i,j];

       end;

     writeln;

   end;

 writeln('Sum: ',sum);

end.

const

 n=5;

var

 a: array [1..N]of integer;

 i,j,k:integer;

begin

 for i:=1 to N do

   begin

     a[i]:=random(41)-16;

     write(a[i]:4);

   end;

 writeln;  

 for i := 1 to N-1 do  

   for j := 1 to N-i do  

     if a[j] < a[j+1] then  

       begin

         k := a[j];

         a[j] := a[j+1];

         a[j+1] := k;

       end;

 for i:=1 to N do

   write(a[i]:4);

end.

(320 баллов)