написать программу для ввода значения величины X целого типа, присваивания величине Y...

0 голосов
534 просмотров

написать программу для ввода значения величины X целого типа, присваивания величине Y действительного типа значения 5.5 , вычисления значения величины Z=X-Y и вывода значения величины Z. Протестировать алгоритм для X=5.5, X=0, X=-10.2


Информатика (12 баллов) | 534 просмотров
0

почему в условии х - целый, а в тестах он уже вещественный

0

читай

0

написано

0

протестировать

0

lf

0

да

0

тестировать подразумевает что программа не будет вылетать с ошибкой -_-

0

Тест (от слова англ. test — «испытание», «проверка»)

Дан 1 ответ
0 голосов

Program fofgogjoj;
var
x:integer;
y,zreal;
begin
Writeln('x=');
Readln(x);
y:=5.5;
z:=x-y;
Writeln('z=',z);
end.

X=5.5,  - ошибка 
 X=0,    -    z=-5.5
 X=-10.2    -   ошибка


(856 баллов)