С 1. Составить алгоритм и написать программу ** вычисление скорости или пути, при...

0 голосов
82 просмотров
С 1. Составить алгоритм и написать программу на вычисление
скорости или пути, при условии, если t>1часа, тогда
вычисляем скорость, иначе путь. Каждую строку программы, прокомментировать.
Входные данные t=2 часа





Информатика | 82 просмотров
0

какой язык программирования?

0

готово

Дан 1 ответ
0 голосов

Алгоритм:
Начало
Ввод t
Если t>1 часа, то
начать выполнение операторов
ввод S;
V=S/t;
вывод V
закончить выполнение операторов
иначе
начать выполнение операторов
ввод V;
S=Vt;
вывод S;
закончить выполнение операторов

Var S,V,t:integer;
begin
read(t);
if t>1 then
begin
read(s);
v:=s/t;
writeln('Скорость=',v);
end
else
begin
read(v);
s:=v*t;
writeln('Расстояние=',s);
end;
end.

(1.2k баллов)