Программисты помогите ,нужно написать задачи в паскале.Задача № 7: Составить...

0 голосов
60 просмотров
Программисты помогите ,нужно написать задачи в паскале.

Задача № 7: Составить программу
вычисления значений функции для любого х по
желанию пользователя:


Задача № 11: Вводятся три значения ускорения свободного падения.
Программа должна проверить, есть ли среди них ускорение свободного
падения.

Задача № 12: Составить программу, которая запрашивает
ввод формул трех кислот и проверяет, есть ли среди них формула серной
кислоты?
image

Информатика (15 баллов) | 60 просмотров
0

во 2 надо все значения вписать?

0

или только 9,8 ?)

0

я тогда 2 значения вобью (9,8 и 10), ок?

0

ок!

0

большое тебе спасибо, ты наверно очень умный)

0

Да не за что, обращайся)

0

обязательно, но постараюсь всё делать сам!

0

хороший настрой)

Дан 1 ответ
0 голосов
Правильный ответ

Задача №7
var x,y:real;
begin
readln(x);
if x<0 then<br>y:=sqr(sin(x))+2
else if x>=0 then
y:=sqrt(x)+sqrt(sqr(x)+1);
writeln(y);
end.
Задание № 12
var s:array[1..3] of string;
i,count:integer;
begin
for i:=1 to 3 do
begin
writeln('Напишите формулу ',i,' кислоты');
readln(s[i]);if (s[i] = 'H2SO4') or (s[i] = 'h2so4')  then
count:=1;
end;
if count=1 then
writeln('Правильная формула есть')
else
writeln('Правильной формулы нет');
end.
Задача №11
var g:array[1..3] of real;
i,count:integer;
begin
for i:= 1 to 3 do
begin
readln(g[i]);
if (g[i] = 9.8) or (g[i] = 10) then
count:=1;
end;
if count = 1 then
writeln('ДА,среди введенных значений есть ускорение свободного падения')
else 
writeln('НЕТ,среди введенных значений нет ускорение свободного падения');
end.

(800 баллов)