Составить программу которая создаёт массив случайных чисел, выводит его ** экран и...

0 голосов
137 просмотров

Составить программу которая создаёт массив случайных чисел, выводит его на экран и вычисляет сумму всех его элементов.


Информатика (12 баллов) | 137 просмотров
Дан 1 ответ
0 голосов

program jfe3;

const n=10; {Это будет кол-во элементов массива}

var a:array [1..n] of integer; i,s:integer;

begin

for i:=1 to n do begin

                            a[i]:=random(100);    {элемент выбирается случайно от 0 до 100}

                            s:=s+a[i];  {Когда эл. присвоился, его значение плюсуется к общ сумме}

                       end;

for i:=1 to n do

writeln(a[i],' ');    {показать сам массив}

writeln(s);   {показать сумму}

readln;  {чтобы окно сразу не закрывалось}

end.

 

Если есть вопросы по программе, пиши в личку. Если надо что-то еще - тоже =)

Удачи)

(1.7k баллов)