Написать программу, которая вводит массив с клавиатуры, удаляет все четные элементы и...

0 голосов
107 просмотров
Написать программу, которая вводит массив с
клавиатуры, удаляет все четные элементы и выводит массив (с изменениями).

Информатика (12 баллов) | 107 просмотров
0

паскаль?

0

да

Дан 1 ответ
0 голосов

Program D1KPxx17;
uses crt;
const n=10;
var
a:array [1..n] of integer;
i:integer;
begin
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if i mod 2<>0 then
write(a[i],' ');
end.

(510 баллов)
0

главное определись что тебе именно надо)

0

да,и оставить нечётные

0

что да? удалить четные ЗНАЧЕНИЯ? тогда исправь строчку

0

if i mod 2<>0 then исправить на If a[i] mod 2<>0 then и все)))

0

не удаляет

0

все 10 чисел ввожу

0

потом она закрывается,открываю и заного вводить надо

0

ты в Turvo работаешь? попробуй без строки с uses crt;

0

ПРОГА РАБОТАЕТ!!!! ИНФА 100%! просто надо в PascalABC запускать или в Turbo(Borland) надо убрать uses crt;