Напишите программу вычисления суммы первых чисел фибоначи, таких, что их значение s не...

0 голосов
45 просмотров

Напишите программу вычисления суммы первых чисел фибоначи, таких, что их значение s не должно превышать типа integer задача для pascal


Информатика (18 баллов) | 45 просмотров
0

МГУ соткать задачу и формулы (если надо)

Дан 1 ответ
0 голосов

Компилятора нету,попробуй этот код
var
n,sum,a,b,c,i:integer;
begin
a:=0;
b:=1;
readln(n);//Посчитать сумму первых n чисел
for i:=1 to n do
begin
sum:=sum+a;
c:=a;
a:=b;
b:=c+a;
end;
writeln(sum);
end.
--------------------------------------------------
//Через repeat until
var
n,sum,a,b,c,i:integer;
begin
a:=0;
b:=1;
i:=0;
readln(n);//Посчитать сумму первых n чисел
repeat
sum:=sum+a;
c:=a;
a:=b;
b:=c+a;
i:=i+1;
until i>=n;
writeln(sum);
end.

(2.4k баллов)
0

Блин, не сможешь сделать через repeat until