Написать программу в Паскале.Предложение состоит из слов, между словами один пробел, а...

0 голосов
49 просмотров

Написать программу в Паскале.Предложение состоит из слов, между словами один пробел, а после последнего слова точка. Найти длину самого длинного слова


Информатика (12 баллов) | 49 просмотров
Дан 1 ответ
0 голосов
var
  x: array of string;
  y: string;

begin
  //readln(y);
  y := 'Привет мой дорогой и прекрасный умопомрач мир';
  x := y.Remove(y.Length - 1).Split(' ');
  y := x[0];
  foreach w: string in x do
    if (y.Length <= w.Length) then<br>      y := w;
  writeln(y.Length);
end.
(16.9k баллов)