Здравствуйте. Помогите сделать задачу ** PascalABC, попросили сделать с помощью...

0 голосов
29 просмотров

Здравствуйте. Помогите сделать задачу на PascalABC, попросили сделать с помощью записей.

Составить программу, которая
вводит данные о студентах:

№ п/п, фамилию, год рождения, пол, курс, вид спорта и выводит: выводит данные только о спортсменках по курсам и
видам спорта в алфавитном порядке.






Информатика (17 баллов) | 29 просмотров
0

Можно сделать ограниченное кол-во записей, к примеру 10.

0

А поставить константу на массив записей и по необходимости менять одно лишь число не вариант?)

0

Самое дурацкой в этой задаче, я бы сказала - количество писанины и убитого времени на всяческие "введите имя"

0

так поможет кто-нибудь сделать? очень необходимо

0

Если меня моя лень и желание поспать по ходу дела не задушат, сделаю.

0

Спасибо, я очень Вам благодарна.

0

Пока еще не за что благодарить

0

Я еще даже не начала, скоро сяду

0

Но всё же Вы одна откликнулись.

0

Готово)

Дан 1 ответ
0 голосов
const n=3;
type student=record
fam:string[20];
year:integer;
sex:string[1];
kurs:integer;
sport:string[30];
end;
var x:array[1..n] of student; i,j:integer;
p:student;
begin
for i:=1 to n do
with x[i] do begin
writeln('сведенья о ',i,' студенте:');
writeln('фамилия: ');
read(fam);
writeln('год рождения: ');
read(year);
writeln('пол( м или ж ): ');
read(sex);
writeln('курс: ');
read(kurs);
writeln('вид спорта: ');
read(sport);
end;

for i:=1 to n-1 do
for j:=i+1 to n do
if x[i].fam>x[j].fam then begin
p:=x[i];
x[i]:=x[j];
x[j]:=p;
end;
for i:=1 to n do begin
with x[i] do
if (sex='ж') then writeln('Фамилия студентки: ',fam,' Курс: ',kurs,' Вид спорта:  ',sport);
end;
end.
(672 баллов)
0

5000? Запросто. В файл так же необходимо забивать данные, как и в массив, верно?) Я просто ставлю константу на количество записей и ради проверки вот приравниваю ее трем. Как только проверка пройдет удачно - ставьте там хоть 5000, хоть 500000:) Что в файл, что в массив забивать вручную в подобных задачах

0

В какой-то степени с файлами работать, конечно, удобнее, но во всем есть плюсы и минусы. Лично я не особо люблю файлы и, как вариант, использую массивы

0

Конечно не имела, я даже еще школу не окончила!)

0

может я и не имела дел с Реальными задами, это еще впереди, но почему бы не написать программу так, как знаешь, чтобы человеку помочь?)

0

И я о том же, благодарю. Трудные задачи подождут, рано ещк