Составьте программу, которая :в строке "Я учусь в школе" заменяет слово "в школе" ** " в...

0 голосов
71 просмотров

Составьте программу, которая :в строке "Я учусь в школе" заменяет слово "в школе" на " в 10-м классе".


Информатика (41 баллов) | 71 просмотров
Дано ответов: 2
0 голосов

Program 1;
Uses CRT;
Var
s: String;
Begin
Writeln('Введите фразу');
read(s);
if (s='Я учусь в школе') then
writeln ('Я учусь в 10-м классе')
end.

(102 баллов)
0 голосов

var
  s: string;

begin
  s:= 'Я учусь в школе';  //Присваиваем начальное значение строковой переменной
  writeln(s);  //Печатаем начальное значение
  Delete(s, 11, 5);  {Удаляем из строки s, начиная с 11 позиции 5 символов (т.е. удаляем слово школа)}
  Insert('10-м классе', s, 11);  {Вставляем строку '10-м классе' в строку s, начиная с 11 позиции}
  writeln(s);  //Печатаем получившуюся строку
end.

  

(2.1k баллов)