Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию. Напишите...

0 голосов
57 просмотров

Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию.
Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.


Информатика (17 баллов) | 57 просмотров
Дан 1 ответ
0 голосов

Программа с НОД
var t,t1,x,y,z:integer;
Function NOD(a, b: integer): integer;
Begin  If a=b then NOD:=a 
else if a>b then NOD:=NOD(a-b, b) 
Else NOD:=NOD(a, b-a);
End;
begin
writeln('Введите 2 числа');
readln(x,y);
t:=NOD(X,Y);
writeln(t);
end.

(42 баллов)