Напишите программу, которая выводит ** экран N (задается константой) случайных букв...

0 голосов
64 просмотров

Напишите программу, которая выводит на экран N (задается константой) случайных букв латинского алфавита в виде пары: заглавная буква, строчная буква. Например, при N = 6 могут быть выведены пары:
Kk
Dd
Qq
Nn
Bb
Rr

Мой набросок:
Program charrr;
Const n=6;
Var ch:char;
i:integer;
Begin
Randomize;
For i:=1 to n do
Begin
ch:=chr(random(26)+97);
writeln(UpCase(ch),ch);
End;
readln;
End.

Нужно сделать без UpCase (обязательно!)


Информатика (177 баллов) | 64 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program charrr;

const
  n = 6;

var
  i,k: integer;

begin
  Randomize;
  for i := 1 to n do
  begin
    k:=random(26) + $41;
    writeln(chr(k),chr(k+32))
  end
end.

(142k баллов)