Помогите пожалуйста с информатикой :) 1. Написать программу. Условие задачи: Написать...

0 голосов
53 просмотров

Помогите пожалуйста с информатикой :)
1. Написать программу.
Условие задачи: Написать программу вывода на экран лесенкой трех последовательно идущих трехзначных чисел. Первое число вводит пользователь, остальные вычисляются в программе.
Пример работы программы:
213
214
215
2. * Составить программу, отгадывающее натуральное чётное число, загаданное пользователем. Ниже представлен рекомендуемый диалог во время работы программы:
Загадайте натуральное чётное число
Прибавьте к нему 4
Уменьшите на 6
Поделите на 2
Что у вас получилось?
3
Вы загадали число 8!!!


Информатика (121 баллов) | 53 просмотров
0

В паскале?

0

Да

Дан 1 ответ
0 голосов
Правильный ответ

1.
program gd;
var a,b,c,d:integer;
begin
writeln('Введите число');
read(a);
b:= a+1;
c:= a+2;
d:= a+3;
writeln(' ',b);
writeln(' ',' ',c);
writeln(' ',' ',' ',d);
end.
2.
program gd1;
var a,b,c,d:integer;
begin
writeln('Загадайте натуральное четное число');
writeln('Прибавьте к нему 4');
writeln('Уменьшите на 6');
writeln('Поделите на 2');
writeln('Что у вас получилось?');
read(a);
b:=a*2;
c:=b+6;
d:=c-4;
writeln('Вы загадали число ',d,'!!!');
end.

(132 баллов)