Срочно! создать программу! тема "организация подпрограмм через функцию" задача дан...

0 голосов
48 просмотров

Срочно! создать программу!
тема "организация подпрограмм через функцию"
задача
дан параллепипед с измерениями а,b, c. Составить программу для нахождения площади полной поверхности, используя подпрограмму нахождения площади прямоугольника.


Информатика (124 баллов) | 48 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Вычисление производим по формуле
S=2(ab+ac+bc)=2(Sp_{(a,b)}+Sp_{(a,c)}+Sp_{(b,c)}); \ Sp_{(x,y)}=x\cdot y

function Sp(x,y:real):real;
begin
  Sp:=x*y
end;

var
  a,b,c,S:real;
begin
  Write('Введите размеры сторон a,b,c: ');
  Read(a,b,c);
  S:=2*(Sp(a,b)+Sp(a,c)+Sp(b,c));
  Writeln('Площадь поверхности равна ',S)
end.

Тестовое решение:
Введите размеры сторон a,b,c: 2.5 3.15 4
Площадь поверхности равна 60.95

(142k баллов)