Информатика 5. Напишите программу, которая вводит трёхзначное число и десятичную цифру....

0 голосов
179 просмотров

Информатика
5. Напишите программу, которая вводит трёхзначное число и десятичную цифру. Определить, входит ли эта цифра в десятичную запись введённого числа.


Информатика (12 баллов) | 179 просмотров
Дан 1 ответ
0 голосов

//PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
var
  a,b,i: integer;
  f:boolean;
begin
  f:=false;
  readln(a);
  readln(b);
  for i:=1 to 3 do begin
    if a mod 10 = b then f :=true;
    a:=a div 10;
  end;
  if f then writeln('входит')
    else writeln('Не входит');
end.

Тестовое решение
для a=123 и b =3

123
3
входит

Для а = 123 и b = 5

123
5
Не входит




(13.9k баллов)