Помогите написать программу в Паскале. Дан массив размера N. Массив отсортировать в...

0 голосов
30 просмотров

Помогите написать программу в Паскале.
Дан массив размера N.
Массив отсортировать в порядке возрастания.
Для отладки программы числа последовательностей сформировать с помощью генератора случайных чисел.


Информатика (277 баллов) | 30 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Uses Crt;
Const
   N = 13;
Var
   A:array[1..N] of integer;
   i,j,Min,B:integer;
Begin
ClrScr;
Randomize;
Write('Исходный массив:');
For i:= 1 to N do
    Begin
    A[i]:=random(2*N+1)-N;
    Write(' ',A[i])
    End;
WriteLn;
Write('Отсортированный массив:');
For i:= 1 to N do
    Begin
    Min:=i;
    For j:= i+1 to N do
        if A[j] < A[Min] then Min:=j;
    B:=A[i];
    A[i]:=A[Min];
    A[Min]:=B;
    Write(' ',A[i])
    End;
ReadLn
End.

(34.0k баллов)