Программирование . Pascal abc. ** вход программе подаются два целых числа m и n, по...

0 голосов
103 просмотров

Программирование . Pascal abc. На вход программе подаются два целых числа m и n, по модулю не превосходящие 10 в 6 степени. Если m делится на n или n делится на m, то требуется вывести 1, в противном случае - случайное число, кроме единицы.


Информатика (753 баллов) | 103 просмотров
0

Условный оператор использовать можно?

0

да

0

Эту задачу сотни раз решали

0

Вы не умеете пользоваться поисковиком, или Вам лень?)

0

я изменил конец задачи , если что

0

так что такую задачу сотни раз не решали

Дан 1 ответ
0 голосов

Var
   m, n: integer;
   
begin
 randomize;
  read(m, n);
   if(m mod n = 0) or (n mod m = 0) then write(1)
   else write(random(99)+2);
 end.

Запусти бонус в приложении и скажи что там:

(3.7k баллов)
0

В Pascal ABC - не запустится.

0

Да только на PascalABC.NET(

0

В задании ясно указан язык - исправляйте.

0

Сейчас нет такого языка PascalABC есть freepascal , object pascal, turbo pascal, Delphi,pascalABC.NET.Так что скорее всего в условии подразумевался именно pascalABC.NET.

0

Глупо говорить, что этого нет, когда по этому языку каждый день тут задачки задают\\\