Написать программу ** паскале 20) Заменить k-й элемент одномерного массива ** 0, если...

0 голосов
73 просмотров

Написать программу на паскале
20) Заменить k-й элемент одномерного массива на 0, если этот элемент четный и на 1 если он нечетный


Информатика (418 баллов) | 73 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

PROGRAM A24;
const
    max = 20;
    
var
    c:array[1..max]of integer;
    x:integer;
    i, k:byte;

BEGIN
  writeln('Заменить k-й элемент одномерного массива на 0, если этот элемент четный и на 1 если он нечетный');
  writeln(' ');

  writeln('Начальный Массив' );
  randomize;
  for i:=1 to max do begin
    c[i]:=random(-64,64);
    write(c[i], ' ');
  end;

  writeln(' ');
  writeln(' ');
 
  write('Введите k='); readln(k);
  writeln(' ');

  if odd(k) then
      c[k]:=1
  else
      c[k]:=0;

  writeln(' ');    
  writeln('Измененный массив' );  
  for i:=1 to max do
    write(c[i], ' ');
END.

(10.8k баллов)
0 голосов
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  var k:=ReadInteger('k=')-1;
  a[k]:=a[k].IsEven?0:1; a.Println
end.

Пример
n= 20
77 8 10 -7 -45 55 -49 -89 28 55 -26 -28 -51 -61 -91 25 75 -18 33 -59
k= 5
77 8 10 -7 1 55 -49 -89 28 55 -26 -28 -51 -61 -91 25 75 -18 33 -59
(150k баллов)
0

Program var begin end

0

у нас просто поймут что это не мы решали

0

С этим бороться на уровне школьников не получится. Это ведь не только по информатике преподают нечто замшелое.