Написать программу, которая вычисляет факториал числа.

0 голосов
69 просмотров

Написать программу, которая вычисляет факториал числа.


Информатика (41 баллов) | 69 просмотров
0

на каком языке?

Дано ответов: 2
0 голосов
Правильный ответ

Var n,f,i: integer;
begin
write('n = ');
readln(n);
f:=1;
for i:=1 to n do f:=f*i;
writeln(n,'! = ',f);
end.

Пример:
n = 6
6! = 720

(194k баллов)
0 голосов

Program E9;
var p, i, n: integer;
begin
write ('введите целое n = ');
readln (n);
p: = 1;
for i: = 1 to n do
p: = p * i;
write (n, '! = ',p);
readln
end.

(148 баллов)