Составьте программу, которая формирует массив из двадцати случайных целых чисел от -30 до...

0 голосов
30 просмотров

Составьте программу, которая формирует массив из двадцати случайных целых чисел от -30 до 30 и подсчитывает количество четных элементов. На экран выводятся исходные массив и результат


Информатика (14 баллов) | 30 просмотров
Дан 1 ответ
0 голосов

var a:array[1..20] of integer;

i,k: integer;

begin

write('Массив: ');

for i:=1 to 20 do

begin

a[i]:=random(61)-30;

if a[i] mod 2 = 0 then k:=k+1;

write (a[i]:3,' ')

end;

writeln;

write('Количество четных элементов ',k)

end.

(1.7k баллов)