Ниже записана программа. Получив ** вход число x, эта программа печатает два числа, L и...

0 голосов
225 просмотров

Ниже записана программа. Получив на вход число x, эта программа печатает два числа, L и M. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 8.
var x, L, M: integer;
begin
readln(x);
L:=0; M:=0;
while x>0 do
begin
L:=L+1;
if (M

begin
M:=x mod 10;
end;
x:= x div 10;
end;
writeln(L); write(M);
end.


Информатика (19 баллов) | 225 просмотров
Дан 1 ответ
0 голосов

Число должно быть трехзначным и начинаться на 8. Максимальное число при котором L=3, а M=8 будет 899

Ответ 899

(1.1k баллов)