Написать программу ** паскале которая определяет, каков процент пробелов во введенном...

0 голосов
56 просмотров

Написать программу на паскале которая определяет, каков процент пробелов во введенном тексте.


Информатика (400 баллов) | 56 просмотров
0

обычный турбопаскаль, который в школах стоит.

Дан 1 ответ
0 голосов
Правильный ответ

Var
  s: string;
  i, n, k: integer;

begin
  writeln('Введите текст');
  readln(s);
  n := Length(s);
  k := 0;
  for i := 1 to n do
    if s[i] = ' ' then k := k + 1;
  writeln('Количество пробелов в тексте- ', k)
end.

Тестовый пример:

Введите текст
А роза упала на лапу Азора, а тут ДВА пробела  , а тут вообще пять:     : Все!
Количество пробелов в тексте- 21


(142k баллов)